• Post Reply Bookmark Topic Watch Topic
  • New Topic

why graph is not appearing?

 
vishnu vardhan brundavanam
Greenhorn
Posts: 11
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi...everyone....
I created an applet which contains a manubar .In that menubar only one manuitem " load file..."(menu item) is there. Which is used to browse the a file which contains a number of values to draw the graph. By that values i want to draw a line graph .
my aim is that when ever i browse a new file , it should take the values form that and draw the graph ...
here is the calling one...


here is the MenuImplimentation Class...




Why the graph is not appearing , even i called the repaint()....


here is the ShowGraph class ....



please help me ....
thank you...
output4.png
[Thumbnail for output4.png]
 
Lester Burnham
Rancher
Posts: 1337
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I don't see code that would add the ShowGraph component to the applet.

Update: You're probably getting an exception in the init method, because "c" is still null when you're calling its "setSize" method. And assigning a value to "c" later does not cause it to be added to the layout.
 
pete stein
Bartender
Posts: 1561
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Is this your code or is it borrowed from other sources as it appears to be an amalgam of things? Also, you appear to be not following recommendations given to you earlier, which is fine, but at least tell us why you choose to ignore the previous recommendations. And why the multiple threads in the forum rather than just sticking with one?
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!