Win a copy of Murach's Python Programming this week in the Jython/Python forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

ljava problem  RSS feed

 
Arvind Purohit
Ranch Hand
Posts: 43
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi All
I have made a webservices, i tried service as main method it is giving result according to my need, but after creating aar file i tried to test it from web browser it is giving error. i am using ant and axis to create web services.

the service name getAllLocality ( cityName, from, noOfRow )
which internally calls method getAllArea( cityName, from, noOfRow )
it is giving problem in getAllArea method
THANKS A LOT
 
Naren Chivukula
Ranch Hand
Posts: 577
Java Notepad Tomcat Server
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Arvind,
Your post lacks many details for someone to atleast understand your problem. I'm sure you can get that if you read your post yourself. To help people asking questions and get effective responses, our members compiled a nice FAQ on How to ask questions on Java Ranch. I suggest you go through that once.

 
Arvind Purohit
Ranch Hand
Posts: 43
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Naren Chivukula wrote:Hi Arvind,
Your post lacks many details for someone to atleast understand your problem. I'm sure you can get that if you read your post yourself. To help people asking questions and get effective responses, our members compiled a nice FAQ on How to ask questions on Java Ranch. I suggest you go through that once.




Hi I am sending detail.



Error while testing from mozila web browser

<soapenv:Reason>

<soapenv:Text xml:lang="en-US">
com.incture.pm.model.service.StoreService.getAllArea(Ljava/lang/String;Ljava/lang/Integer;Ljava/lang/Integer;)Ljava/util/List;
</soapenv:Text>
</soapenv:Reason>


What is reason
PLEASE Help me
 
Naren Chivukula
Ranch Hand
Posts: 577
Java Notepad Tomcat Server
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Arvind,

I have made a webservices, i tried service as main method it is giving result according to my need


Did you mean you actually created a web service, deployed and tested the service "on client side" using a Java Standalone program i,e. from main method?

If it is already deployed and running, why do you want to deploy again as .AAR? You could still test web service on browser and get same result in the same way as you're getting in Java client program.



 
Arvind Purohit
Ranch Hand
Posts: 43
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Naren Chivukula wrote:Hi Arvind,

I have made a webservices, i tried service as main method it is giving result according to my need


Did you mean you actually created a web service, deployed and tested the service "on client side" using a Java Standalone program i,e. from main method?

If it is already deployed and running, why do you want to deploy again as .AAR? You could still test web service on browser and get same result in the same way as you're getting in Java client program.



No I run it as main method( simple java program )

I solved this issue by changing backend service . i am still unable to root cause it.
But issue is solved
Thanks all for your help
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!