Win a copy of Functional Reactive Programming this week in the Other Languages forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

java.lang.IllegalArgumentException: input == null!

 
N ssss
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

We use Eclipse for development of a swing application. While development we run the application from Eclipse itself but when on production, the user gets a URL to access the same application. We use java Web-Start to load the swing application to the user's end.

Now I am facing a very awkward error. When I am running the application in Eclipse as an application it works fine but when I deploy the application on to the Tomcat web server it gives me a java.lang.IllegalArgumentException: input == null! while opening a form.

The war is generated using the ant build tool.

I placed log messages to the code to debug so that i could make out where this exception is coming from. I could find the place where the code, when deployed on the server throws the exception. The code looks good to me. Are there any other reasons to this exception? How can i fix this issue?

The exception occurs when a Model is set to the JTable, some thing like this:
JTable table=new JTable();
TreeViewModel treeViewModel = new TreeViewModel();
table.setModel(treeViewModel);

this same code works fine at other place.
 
Jesper de Jong
Java Cowboy
Saloon Keeper
Posts: 15495
43
Android IntelliJ IDE Java Scala Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
"N ssss", welcome to JavaRanch. Please read your private messages for an administrative message from JavaRanch.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic