• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Baffling Ant version error

 
Dave Alvarado
Ranch Hand
Posts: 436
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

We are trying to run a custom Ant task we have written. The task requires the selenium-server.jar library to run. However we are noticing something perplexing. Normally, we get this Ant version output ...



However, when we add the selenium-server.jar file to our Ant's lib directory, we get



Does anyone have any idea what's going on or how to troubleshoot this version thing further? - Dave
 
Lester Burnham
Rancher
Posts: 1337
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Have you looked inside the selenium-server.jar to see of there are Ant classes hiding? Unlikely, I guess, but worth a check.
 
Dave Alvarado
Ranch Hand
Posts: 436
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Within that jar file, there are two packages ...

./org/apache/tools/ant/
./org/hamcrest/generator/qdox/ant

but why is that a concern? Is there a way that I can figure out what classes are conflicting with Ant? - Dave
 
Lester Burnham
Rancher
Posts: 1337
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
It's a concern because org/apache/tools/ant is the main Ant package. It's also what's in the ant.jar file that's in the Ant lib directory - setting you up for version clashes.

See if you can find the Selenium classes in some other jar file by themselves, or create a new jar file from them that doesn't contain the Ant classes.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic