This week's book giveaway is in the Jython/Python forum.
We're giving away four copies of Murach's Python Programming and have Michael Urban and Joel Murach on-line!
See this thread for details.
Win a copy of Murach's Python Programming this week in the Jython/Python forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

WS-Security, <wsse:Security> Missing in client request  RSS feed

 
Ravi Choudhari
Greenhorn
Posts: 9
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

I am trying to implement a secure webservice using WS-Security in JBoss 5.1 following the steps in http://www.developer.com/java/other/article.php/3802631/Securing-Web-Services-in-JBoss-Application-Server-with-WS-Security.htm,

On the server Side I have:

Service:




standard-jaxws-endpoint-config.xml



jboss-wsse-server.xml



I hv copied jboss-wsse-server.xml, standard-jaxws-endpoint-config.xml, server.keystore, server.truststore to META-INF directory of the server project.


And on the client side I have:

standard-jaxws-client-config.xml



jboss-wsse-client.xml



Client Application:



I have copied standard-jaxws-client-config.xml, jboss-wsse-client.xml and client.keystore, client.truststore to META-INF directory of the client.

But, When there is request from the client, I am getting the following Execption.

Exception in thread "main" javax.xml.ws.soap.SOAPFaultException: This service requires <wsse:Security>, which is missing.

I have checked the request SOAP message & response messages, The client is not adding any <wsse:Security>, which is expected by the server.

 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!