Win a copy of Murach's Python Programming this week in the Jython/Python forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

Mobile UI defect  RSS feed

 
raviG gupta
Greenhorn
Posts: 11
Eclipse IDE Firefox Browser Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Hi evryone .. This one is very urgent for me ..
I m fixing up a code issue ..
the problem arises with respect to viewing in the mobile. A page having a text link("abc xyz") its linking to other page as usual .
here we have two words for the link.
the problem is when viewing in the mobile environment or rather saying that when we zoom and decrease the size of the explorer the above two links are coming in separate lines...
this is happening when we write code in jsf and render it in the HTML output ..
'abc xyz | fxz | asd ' .. this type of link is there please help me out as i have tried every bit of it.
thanks
 
Tim Holloway
Bartender
Posts: 18531
61
Android Eclipse IDE Linux
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
It is a little unclear whether you are having an issue with a single 2-word link breaking into 2 lines or 2 links (one of which may have 2 words in it) breaking lines in an inconvenient place.

For the second instance, you can enclose the links in an h:panelGrid control and have each link be a separate cell. Ajust the control options and style settings to suit.

For the first instance, you can replace the space between the words with a non-break space character. In traditional HTML, this is " ". In XML JSF view definitions, there's no built-in support for nbsp, so you'll either have to add an entity definition to your view or use the brute-force character code. I think it's "¡", but I'm not sure.
 
raviG gupta
Greenhorn
Posts: 11
Eclipse IDE Firefox Browser Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello Tim thanks for figuring it out quickly.Yes its the first instance. but still i have tried and i m not able to get it.

i m trying again.. i have figure it out as when i m separating the anchor tag from the output screen using firebug the display is perfectly rite.. so i m not able to do it in the code itself as if i m doing the links are separated ..

to be clear there are two adjacent link .. lke below mentioned .. the first link is having two words and second link is having a single word.

abc xyz | asd

| --- this is just a separator.
abc xyz --- first link
asd --- second link

thanks if ne one can help ..
and once again thnxs Tim if you can further help me..
 
raviG gupta
Greenhorn
Posts: 11
Eclipse IDE Firefox Browser Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi evryone please help me out .

thank you
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!