• Post Reply Bookmark Topic Watch Topic
  • New Topic

Unable to define/override @Version on a subclass

 
Nps Ferreira
Greenhorn
Posts: 9
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi all,

I´m using the InheritanceType.JOINED strategy, but im getting this error when trying to define the @Version column.

here is my structure



This error occur when i put the @version annotation in my subclass, i get it, but i want to fill the version column with the value of the parent class (Resource) this dosent happen.

Anyone have any idea or passed for something like this?

cheers

 
No one can make you feel inferior without your consent - Eleanor Roosevelt. tiny ad:
the new thread boost feature: great for the advertiser and smooth for the coderanch user
https://coderanch.com/t/674455/Thread-Boost-feature
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!