• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic


vibeeshan kambli
Ranch Hand
Posts: 41
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am trying to use J2ee application client and webservice together on Websphere server V7.
Here is what's happening , any help is greatly appreciated.

We have older application that uses J2ee application client to run batch.
This batch does several things but I recently integrated a jax-ws webservice cleint.
This webservice client invokes .Net webservice. I took the wsdl from .Net service
and generated proxy classes.
When I invoke this application with in RSA, it runs fine but when I run this batch application on unix server using shell script
I will get the following error

Caused by: java.lang.ClassNotFoundException: com.ibm.ws.webservices.exception.WSDLPostProcessingException
at java.lang.Throwable.<init>(Throwable.java:80)
at java.lang.ClassNotFoundException.<init>(ClassNotFoundException.java:77)
at org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:351)
at org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:347)
at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:83)
at java.lang.ClassLoader.loadClass(ClassLoader.java:618)
... 71 more

I have spcified com.ibm.jaxws.thinclient_7.0.0.jar in the classpath
I greatly appreciate your help. Thank you.

  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic