Win a copy of Kotlin in Action this week in the Kotlin forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

JSF Configuration settings in WAS  RSS feed

 
Gayathri Rajamani
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

Can any one please tell me, where i can find the recommeded settings for JSF in WAS?
My application sometime works, sometime does not, after deployment.
The issue is when i click on a link on JSF page(xhtml), it does not display the result/destination jsf page. However, behind the scene, it forwards the request to middleware java component and then executes a query in db, fetches data, but it is not displaying the data in result page.

Please help.

Thanks,
Gayathri.
 
Ganesh Gopalakrishnan
Ranch Hand
Posts: 35
 
Gayathri Rajamani
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Please find more information about class loader settings.
http://publib.boulder.ibm.com/infocenter/wasinfo/v7r0/index.jsp?topic=/com.ibm.websphere.base.doc/info/aes/ae/tweb_jsf.html

Class loader settings need to be done in JVM level, App level and also WAR level.

In WAS Admin console - in the JVM level,

Application servers > xxx_Server1

Server specific Application Settings

class loader policy Single
class loader mode Parent_Last

The option needs to be selected in(App Level) Enterprise Applications > AppName > Class loader

"Class loaded with application class loader first."

and also in (War level)

Enterprise Applications >AppName > Manage Modules > Appxx.war

finally resolved this issue.
 
With a little knowledge, a cast iron skillet is non-stick and lasts a lifetime.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!