• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Devaka Cooray
  • Knute Snortum
  • Paul Clapham
  • Tim Cooke
Sheriffs:
  • Liutauras Vilda
  • Jeanne Boyarsky
  • Bear Bibeault
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Ron McLeod
  • Piet Souris
  • Frits Walraven
Bartenders:
  • Ganesh Patekar
  • Tim Holloway
  • salvin francis

Running tomcat apache 5.5 on fedora 14 problem  RSS feed

 
Ranch Hand
Posts: 634
Chrome Eclipse IDE Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
i have changed the permissions of tomcat folder
stiill
firstly,i did this
------------------------------------------------
[mohit@localhost local]$ /usr/local/tomcat/bin/startup.sh
Using CATALINA_BASE: /usr/local/tomcat
Using CATALINA_HOME: /usr/local/tomcat
Using CATALINA_TMPDIR: /usr/local/tomcat/temp
Using JRE_HOME: /usr/java/jdk1.6.0_23/bin/java
Using CLASSPATH: /usr/local/tomcat/bin/bootstrap.jar
[mohit@localhost local]$

--------------------------------------------------------
i put the address localhost in the browser, and got the following error

Forbidden

You don't have permission to access / on this server.
Apache/2.2.17 (Fedora) Server at localhost Port 80



then,i tried to shutdown the service and this is what happened
-----------------------------------------------------------------
[mohit@localhost local]$ /usr/local/tomcat/bin/shutdown.sh
Using CATALINA_BASE: /usr/local/tomcat
Using CATALINA_HOME: /usr/local/tomcat
Using CATALINA_TMPDIR: /usr/local/tomcat/temp
Using JRE_HOME: /usr/java/jdk1.6.0_23/bin/java
Using CLASSPATH: /usr/local/tomcat/bin/bootstrap.jar
/usr/local/tomcat/bin/catalina.sh: line 330: /usr/java/jdk1.6.0_23/bin/java/bin/java: Not a directory


-------------------------------------------------------------
i think the service didn't started ..

please help
 
author
Posts: 5856
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Looks like to left off the port number in the URL - Tomcat uses port 8080, not port 80. You should have used the URL http://localhost:8080

Also, this is incorrect:

using JRE_HOME: /usr/java/jdk1.6.0_23/bin/java



You should set JAVA_HOME (or JRE_HOME?) to /usr/java/jdk1.6.0_23

 
Mohit G Gupta
Ranch Hand
Posts: 634
Chrome Eclipse IDE Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have used the URL http://localhost:8080
http://localhost:8180
localhost:80

none of them works

and give the following page:

Unable to connect

I even disabled the firewall
 
Bartender
Posts: 20743
124
Android Eclipse IDE Java Linux Redhat Tomcat Server
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
1. Issue the command "netstat -lnp | grep 8080". Look for Port "8080". If it's not being listened to, Tomcat did not start,

2. If a process is listed on port "8080", the last column of the output from step 1 should be "nnnn/java". If it doesn't say "java", then something else is already running on that port.

3. At this point, you might want to shut down Tomcat and start fresh. Issue the "TOMCAT_HOME/catalina.sh stop" command (or "stop.sh") to shutdown Tomcat, wait a minute or 2, then repeat step 1. If, after 2 or 3 tries Tomcat hasn't shut down, issue a "kill -9 nnnn" command, wait, do step 1 again until Tomcat has definitely stopped running. If Tomcat absolutely positively can not be terminated, shut down the whole machine, power off, wait 30 seconds and reboot. And if a tomcat lists as running after all that, then somehow something's automatically launching a Tomcat server and we need to find out what.

4. Otherwise, we should at this point not longer have a copy of Tomcat running. Do the following:



Note that all of the above end with "/*". You don't want to delete those directories, just their contents! Also, of course, replace "TOMCAT_HOME" with the actual directory path where your copy of Tomcat lives.

5. Now start Tomcat. You can use the command "tail -f TOMCAT_HOME/log/catalina.out" to watch it come up. Normally a flurry of activity will ensue as Tomcat starts and initiates the deployed applications. After a minute or 2 the message "tomcat started in nnnnn seconds" should indicate that Tomcat is ready for use. Verify that using the netstat command from step 1 and URL "http://localhost:8080".

If that doesn't get you started, ask for help in the Tomcat forum, since you'll find more useful advice over there. You don't really have a Linux-specific problem I don't think.
 
Gravity is a harsh mistress. But this tiny ad is pretty easy to deal with:
how do I do my own kindle-like thing - without amazon
https://coderanch.com/t/711421/engineering/kindle-amazon
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!