Win a copy of Programmer's Guide to Java SE 8 Oracle Certified Associate (OCA) this week in the OCAJP forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Deploy Struts2 blank application on JBoss 5

 
Anup Om
Ranch Hand
Posts: 62
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello everybody,

I am trying to deploy struts 2.2.1 blank war onto JBOSS, but getting following errors. The application deploys and runs fine on Tomcat6.
Please help me figure out where I am going wrong. Thanks for your help in advance.

 
uttam kumar
Ranch Hand
Posts: 128
Eclipse IDE Java Oracle
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Caused by: java.lang.NoClassDefFoundError: freemarker/template/TemplateException


Have you added required jars for your application into the lib directory?
 
Anup Om
Ranch Hand
Posts: 62
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello Uttam,

Thanks for the reply. I was all the way looking in eclipse and was able to see freemarker jar in the lib folder of the web app in eclispe. When I deploy the application (through 'Add and Remove' server resources), the freemarker jar and javaassit jar are disappearing. I don't understand.

If I copy and paste the war file in deploy folder, the application deploys and runs fine.

Where am I going wrong in deploying the app? Is there are better approach to deploy applications?

 
uttam kumar
Ranch Hand
Posts: 128
Eclipse IDE Java Oracle
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
May be some problem with your eclipse setting. Double check your eclipse configuration.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic