This week's book giveaway is in the Features new in Java 9 forum.
We're giving away four copies of Java 9 Revealed and have Kishori Sharan on-line!
See this thread for details.
Win a copy of Java 9 Revealed this week in the Features new in Java 9 forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

NoSuchTableException when (trying) to use DBUnit  RSS feed

 
William Fernandes
Greenhorn
Posts: 16
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello,

I'm trying to use DBUnit (version 2.4.8) because I like the idea but the framework is detestable.

I'm following the Getting Started session of the official website, doing the most simple basic test, but it's not working when I try to run the test:


My dataset.xml (which it loads - located in the classpath, above src folder):


The error stack I get when I run my test:


Yes, the table users does exist in my local MySQL. I tried to debug and I saw that the Map which it loads with the table names comes empty, so it considers that the current schema is empty, which is not.

What am I doing wrong?

Thanks
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!