• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Jeanne Boyarsky
  • Devaka Cooray
  • Paul Clapham
Sheriffs:
  • Tim Cooke
  • Knute Snortum
  • Bear Bibeault
Saloon Keepers:
  • Ron McLeod
  • Tim Moores
  • Stephan van Hulst
  • Piet Souris
  • Ganesh Patekar
Bartenders:
  • Frits Walraven
  • Carey Brown
  • Tim Holloway

Problem With My First Web Services Experiment

 
Ranch Hand
Posts: 325
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I downloaded a ZIP file from the National Cancer Institue (NCI). The ZIP file contains conf, lib, src directoris as well as a build.xml file. NCI allows web services client to access its database. For demonstration purpose, users are supposed to see some results simple by issuing a command: ant runwsdemo in a DOS window.

My effort was partially successful because I was able to see some data returned. However, there are a number of problems. I am seeking help by posting the log below.
[quote]
Buildfile: C:\cabio\cabio43_ws_client\build.xml
init:
[echo] *****************************************************************
[echo] *** caCORESDK: Preparing directories
[echo] *****************************************************************
compile:
[echo] *****************************************************************
[echo] *** caCORESDK: Compiling the generated beans
[echo] *****************************************************************
runwsdemo:
[java] Jan 11, 2011 8:55:18 AM org.apache.axis.utils.JavaUtils isAttachmentSupported
[java] WARNING: Unable to find required classes (javax.activation.DataHandler and javax.mail.internet.MimeMultipart). Attachment support is disabled.
[java] Connecting to http://cabioapi.nci.nih.gov/cabio41/services/caBIOService
[java] 1.Version: 4.0
[java] ====================================================================
[java] 2.Number of records returned per Query: 1000
[java] ====================================================================
[java] 3.Total number of Genes found: 1000
[java] ====================================================================
[java] Exception in thread "main" AxisFault
[java] faultCode: {http://schemas.xmlsoap.org/soap/envelope/}Server.userException
[java] faultSubcode:
[java] faultString: org.xml.sax.SAXException: Invalid element in gov.nih.nci.cabio.domain.Taxon - multipleAlignmentCollection
[java] faultActor:
[java] faultNode:
[java] faultDetail:
[java] {http://xml.apache.org/axis/}hostname:cbapp-p1002.nci.nih.gov
[java] org.xml.sax.SAXException: Invalid element in gov.nih.nci.cabio.domain.Taxon - multipleAlignmentCollection
[java] at org.apache.axis.message.SOAPFaultBuilder.createFault(SOAPFaultBuilder.java:222)
[java] at org.apache.axis.message.SOAPFaultBuilder.endElement(SOAPFaultBuilder.java:129)
[java] at org.apache.axis.encoding.DeserializationContext.endElement(DeserializationContext.java:1087)
[java] at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.endElement(Unknown Source)
[java] at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanEndElement(Unknown Source)
[java] at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl$FragmentContentDriver.next(Unknown Source)
[java] at com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(Unknown Source)
[java] at com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.next(Unknown Source)
[java] at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(Unknown Source)
[java] at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(Unknown Source)
[java] at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(Unknown Source)
[java] at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(Unknown Source)
[java] at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(Unknown Source)
[java] at com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSAXParser.parse(Unknown Source)
[java] at javax.xml.parsers.SAXParser.parse(Unknown Source)
[java] at org.apache.axis.encoding.DeserializationContext.parse(DeserializationContext.java:227)
[java] at org.apache.axis.SOAPPart.getAsSOAPEnvelope(SOAPPart.java:696)
[java] at org.apache.axis.Message.getSOAPEnvelope(Message.java:435)
[java] at org.apache.axis.handlers.soap.MustUnderstandChecker.invoke(MustUnderstandChecker.java:62)
[java] at org.apache.axis.client.AxisClient.invoke(AxisClient.java:206)
[java] at org.apache.axis.client.Call.invokeEngine(Call.java:2784)
[java] at org.apache.axis.client.Call.invoke(Call.java:2767)
[java] at org.apache.axis.client.Call.invoke(Call.java:2443)
[java] at org.apache.axis.client.Call.invoke(Call.java:2366)
[java] at org.apache.axis.client.Call.invoke(Call.java:1812)
[java] at TestWS.main(TestWS.java:98)
[java] Java Result: 1
BUILD SUCCESSFUL
Total time: 3 seconds

[/quote]

 
Natalie Kopple
Ranch Hand
Posts: 325
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Ladies and gentlemen, I have figured out what the problem was. Sorry for bothering you. Thank you.
 
Don't get me started about those stupid light bulbs.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!