• Post Reply Bookmark Topic Watch Topic
  • New Topic

java.net.SocketException: select failed  RSS feed

 
Rajesh Kumar.P
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi ,

I tried a simple program in RMI .

My coding is

try{
System.out.println("Entered Server Program");
AddImplementation addImplementationObject = new AddImplementation();
System.out.println("Object Created");
Naming.rebind("//localhost:8888/AddImplementationObject",addImplementationObject);
System.out.println("Server Started");
} catch(Exception exception) {
System.out.println("Exception occurred \n" + exception);
}



After starting my RMI registry by
start rmiregistry 8888


my RMI registry started successfully.

When i run this program , i get the output as

Entered Server Program
Object Created


and after this i get the following error in my RMI registry.

11 Jan, 2011 8:49:44 PM sun.rmi.transport.tcp.TCPTransport$AcceptLoop executeAcceptLoop
WARNING: RMI TCP Accept-8888: accept loop for ServerSocket[addr=0.0.0.0/0.0.0.0,port=0,localport=8888] throws
java.net.SocketException: select failed
at java.net.PlainSocketImpl.socketAccept(Native Method)
at java.net.PlainSocketImpl.accept(PlainSocketImpl.java:390)
at java.net.ServerSocket.implAccept(ServerSocket.java:453)
at java.net.ServerSocket.accept(ServerSocket.java:421)
at sun.rmi.transport.tcp.TCPTransport$AcceptLoop.executeAcceptLoop(TCPTransport.java:369)
at sun.rmi.transport.tcp.TCPTransport$AcceptLoop.run(TCPTransport.java:341)
at java.lang.Thread.run(Thread.java:619)


Why this error occurs ? What should i change ?
 
Deepak Chopra
Ranch Hand
Posts: 433
Eclipse IDE Firefox Browser Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Did you check if your client application is running?
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!