Help coderanch get a
new server
by contributing to the fundraiser
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Paul Clapham
  • Liutauras Vilda
Sheriffs:
  • paul wheaton
  • Rob Spoor
  • Devaka Cooray
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Frits Walraven
  • Tim Moores
Bartenders:
  • Mikalai Zaikin

Tomcat 7.05/Windows 2008 (64bit) issues (solved) (Commons Daemon problem)

 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I just managed to install Tomcat 7.05 on Windows 2008 (64bit). It took me a day, partly 2008 being a pain in the ass, but at least half a day because of Tomcat. (I have been using Tomcat since version 3... so I am used to something...)

I will not claim that everything I did was relevant, but I now have a working starting/stopping installation that has icons where they should be.
To start with I dropped the UserAccessControl. Miscrosoft insists that stuff is not compatible with 2008 when of course the reality is the other way around... I love the stability of Windows as a base platform, but i hate that attitude. Anyway, drop the UAC and things start happening. After installation i set the tomcat7.exe and tomcat7w.exe to run as administrator for all users. Stuff still did not start and as per many other posts I removed the tomcat.pid entry from the configuration (and deleted the file) (what is this nonsense anyway!!!)

I could now sucessfully start and stop the service using the Monitor thingy.

However..... the service did NOT start up (or so it seemed) when restarting the machine. This of course is unacceptable. So I wasted a lot of time to find out why it does not start automatically.
Only when i started using my brain I found that it DOES start... unfortunately it also immediately shuts down

[2011-01-12 17:01:23] [info] Commons Daemon procrun (1.0.4.0 64-bit) started
[2011-01-12 17:01:23] [info] Running 'Tomcat7' Service...
[2011-01-12 17:01:23] [info] Starting service...
[2011-01-12 17:01:24] [info] Service started in 1528 ms.
[2011-01-12 17:01:28] [info] Run service finished.
[2011-01-12 17:01:28] [info] Commons Daemon procrun finished

I then decided it was a problem with the Commons Daemon thingy (tomcat7.exe). I dropped in the one from Tomcat 6.0.29 (which did start/stop correctly) renamed it to tomcat7 and presto. Everything works fine

So... Commons Daemon Service Runner 1.0.4.0 is INCOMPATIBLE with Windows 2008, whereas 1.0.2.0 works fine (have not tried 1.0.3.0)

I think this is a very obscure 'bug'.


Hope this helps someone

Erik


Update:
1. The same problem occurs on Windows 7 Home premium edition (64 bit)
2. Commons Daemon 1.0.3.0 works fine

More update:
Just downloaded the latest version 1.0.5.0 from the Commons Daemon site. Works fine...



 
Just the other day, I was thinking ... about this tiny ad:
We need your help - Coderanch server fundraiser
https://coderanch.com/t/782867/Coderanch-server-fundraiser
reply
    Bookmark Topic Watch Topic
  • New Topic