• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Tim Cooke
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Liutauras Vilda
Sheriffs:
  • Jeanne Boyarsky
  • Rob Spoor
  • Bear Bibeault
Saloon Keepers:
  • Jesse Silverman
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
Bartenders:
  • Piet Souris
  • Al Hobbs
  • salvin francis

URLClassPath source for jdk1.6_0_23

 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
HI!
I'm looking for the source code for sun.misc.URLClassPath, appropriate for jdk1.6_0_23. The versions I have managed to find on the Internet do not suit this particular JDK.
The reason for seeking this source code is that I keep receiving the following error when trying to debug a Spring application under Eclipse:


Thread [main] (Suspended (exception FileNotFoundException))
URLClassPath$JarLoader.getJarFile(URL) line: 644
URLClassPath$JarLoader.access$600(URLClassPath$JarLoader, URL) line: 540
URLClassPath$JarLoader$1.run() line: 607
AccessController.doPrivileged(PrivilegedExceptionAction<T>) line: not available [native method]
URLClassPath$JarLoader.ensureOpen() line: 599
URLClassPath$JarLoader.<init>(URL, URLStreamHandler, HashMap<String,Loader>) line: 583
URLClassPath$JarLoader$3.run() line: 810
AccessController.doPrivileged(PrivilegedExceptionAction<T>) line: not available [native method]
URLClassPath$JarLoader.getResource(String, boolean, Set<String>) line: 806
URLClassPath$JarLoader.getResource(String, boolean) line: 765
URLClassPath.getResource(String, boolean) line: 169
URLClassLoader$1.run() line: 194
AccessController.doPrivileged(PrivilegedExceptionAction<T>, AccessControlContext) line: not available [native method]
Launcher$AppClassLoader(URLClassLoader).findClass(String) line: 190
Launcher$AppClassLoader(ClassLoader).loadClass(String, boolean) line: 307
Launcher$AppClassLoader.loadClass(String, boolean) line: 301
Launcher$AppClassLoader(ClassLoader).loadClass(String) line: 248


I know that someone has worked this problem around by switching Eclipse's workspace, but in my case this doesn't work. I need to find out what the real problem is.
Regards,
Andrzej.
 
Greenhorn
Posts: 4
Eclipse IDE Spring Tomcat Server
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I was also facing the same problem and that too for spring-framework-3.1.0.RC1/dist/org.springframework.aspects.jar, but I am able to debug my application now after adding VM argument as -javaagent:<path to aspectjweaver> although the URLClassPath$JarLoader exception stack is still coming.
I am sure what I did is not the solution and still looking for an workaround.
 
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi,

I had the same error with Spring 3.0.5.RELEASE, but only during debugging in Eclipse. I had a clear look at the jar file and noticed that in the INDEX.LIST file in the META-INF another jar was referenced. The jar file was named org.springframework.aspects-3.0.5.RELEASE.jar but the INDEX.LIST referenced org.springframework.aspects.jar. After I renamed my org.springframework.aspects-3.0.5.RELEASE.jar to org.springframework.aspects.jar everything went fine.
 
reply
    Bookmark Topic Watch Topic
  • New Topic