This week's book giveaway is in the Agile and Other Processes forum.
We're giving away four copies of The Journey To Enterprise Agility and have Daryl Kulak & Hong Li on-line!
See this thread for details.
Win a copy of The Journey To Enterprise Agility this week in the Agile and Other Processes forum! And see the welcome thread for 20% off.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Jeanne Boyarsky
  • Liutauras Vilda
  • Campbell Ritchie
  • Tim Cooke
  • Bear Bibeault
Sheriffs:
  • Paul Clapham
  • Junilu Lacar
  • Knute Snortum
Saloon Keepers:
  • Ron McLeod
  • Ganesh Patekar
  • Tim Moores
  • Pete Letkeman
  • Stephan van Hulst
Bartenders:
  • Carey Brown
  • Tim Holloway
  • Joe Ess

Can't change the welcoem file  RSS feed

 
Ranch Hand
Posts: 68
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I was circling oround this problem cause it wasn't the top priority but now I need to complete this and can't see for any way to fix it.
My problem is that I can't change the welcome. When I first created the project i set it up in a index.html file - a simple blank page with just one sign "Please wait for the web application to start". However now I want it to look more fancy and it needs to be a static html. I was changing the index.html file but after deploying the app nothing happens - still the same page. I then tried to rename the file to weclome.html followed by changes to the web.xml:

But still - the page is stuck as it was with no changes. I look at the war file and the project deployed on tomcat directory - the new file is there and looks like it should look. I tried adding the project folder name before filename in web.xml but still nothing. Why the old one is still loading? Do I need to change sth else? And more improtant - how is the previous one loading although it's not in the project directory any more?

I am using JSF 1.2 with rich faces and tomcat 6
 
Ranch Hand
Posts: 774
  • Likes 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello Adam,

Try to clean your cache or restart the browser so that a new session is opened.
HTH,
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!