Win a copy of Functional Reactive Programming this week in the Other Languages forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Question on Ant script error in my build.xml file in the Eclipse IDE

 
Melinda Savoy
Ranch Hand
Posts: 387
Eclipse IDE Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Currently I am working on my local XP box in Eclipse Helios. The version of ANT that I have loaded is apache-ant-1.8.2. I am a NEWBIE in regards to ANT and need some help.

The error I am getting in the build.xml file is: Default target dist does not exist in this project

However, when I go to the Eclipse workspace where I have my project: C:\eclipse-3.6-helios-SR1\Workspace\TestWebService\RequisitionWS

And the directory structure for my project, RequisitionWS, is:

.settings
build folder
dist folder
src folder
WebContent folder
.classpath
.project
build.xml

My build.xml file is as follows:



Can someone please tell me what I'm doing wrong? ANY help/direction would be greatly appreciated.

Thanks.


 
J J Singh
Greenhorn
Posts: 12
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi

Read the start of build.xml

<project name="RequisitionWS" default="dist" basedir=".">

it says default target is dist

But there is no target with name dist defined

there should be some target named dist similar to this

<target name="dist">

///some tasks


</target>

Hope it helps

 
Melinda Savoy
Ranch Hand
Posts: 387
Eclipse IDE Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thank you for the reply. That did it.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic