• Post Reply Bookmark Topic Watch Topic
  • New Topic

Facelet debug error page always enabled

 
Olav Engelsastro
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi.

I'm using JSF 1.2, with Richfaces 3.3.3 and Facelets 1.1.15 in my web application.

I'm having trouble disabling the facelets debug error page. I have tried setting this parameter in web.xml:

<context-param>
<param-name>facelets.DEVELOPMENT</param-name>
<param-value>false</param-value>
</context-param>

But is seems to have no impact. Any ideas anyone?

Thanks
-Olav

 
Olav Engelsastro
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have tracked this down to only being a problem on Weblogic.
Have tried overriding the facelets.Development param from the command line, as well as running in production mode.
But the problem persists...
 
Olav Engelsastro
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Installing a weblogic domain in production mode (not just setting production mode in setDomainEnv), fixed it.
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!