• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Jeanne Boyarsky
  • Tim Cooke
Sheriffs:
  • Liutauras Vilda
  • paul wheaton
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Tim Holloway
  • Stephan van Hulst
  • Carey Brown
  • Frits Walraven
Bartenders:
  • Piet Souris
  • Himai Minh

Problem with FTP Server while storing file with special char name,

 
Ranch Hand
Posts: 44
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi,

We have FTP server setup at server side which is of Apache Mina,

I have Apache FTPClient to communicate with FTP server, and sending file with special char (UTF-8) to store, I have already setup encoding as UTF-8 at client side, now FTP server receive the file and store it into destination folder but it replace ‘?’ into filename wherever special char is found.

Does any body have an idea what can solve this problem?



My file name e.g: På følgende du yderligere information og hjælp1.mov
FTP server store it as P?_f?lgende_du_yderligere_information_og_hj?lp1.mov.md5
 
Bartender
Posts: 2700
IntelliJ IDE Opera
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I've no idea how to solve your problem but just thinking out loud: can your OS store files with that kind of name?
 
Ashok Mor
Ranch Hand
Posts: 44
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
It get resolved as it was the problem with jvm considering charsetfor linux based on LANG proeprty, so i set it as LANG=en_GB.UTF-8, and issue get resolved.

 
Ashok Mor
Ranch Hand
Posts: 44
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
It resolved with the setting like, LANG=en_GB.UTF-8
 
Sheriff
Posts: 3036
12
Mac IntelliJ IDE Python VI Editor Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
That's great you were able to resolve your problem. Just to clarify, the LANG property is a shell environment variable, right?
 
Oh sure, it's a tiny ad, but under the right circumstances, it gets bigger.
Free, earth friendly heat - from the CodeRanch trailboss
https://www.kickstarter.com/projects/paulwheaton/free-heat
reply
    Bookmark Topic Watch Topic
  • New Topic