Granny's Programming Pearls
"inside of every large program is a small program struggling to get out"
JavaRanch.com/granny.jsp
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Paul Clapham
  • Liutauras Vilda
Sheriffs:
  • paul wheaton
  • Rob Spoor
  • Devaka Cooray
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Frits Walraven
  • Tim Moores
Bartenders:
  • Mikalai Zaikin

Link problem

 
Ranch Hand
Posts: 66
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I have placed 2 links,for the first the text is only underlined, and link is not working.
For the second link it is neither underlined, neither is working.
Here is the code:



CSS:

Any suggestion will be high appreciated, since I cannot really see where is the problem..
Thank You!
 
author
Posts: 15385
6
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
The CSS says text decoration is none so of course there is no underline.

links seem to work fine for me: http://jsbin.com/aboho3

Eric
 
Nicol Green
Ranch Hand
Posts: 66
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi Eric!
Thank You for a quick response!

When I said it is not underlined, I thought the first one it is, but the second is not, and it is not clickable.

So, it is working.. In my code not working at all. Possibly that there is a problem with divs ? What are the situations when links are not working ?
My code is entirely the same, although one level up I have div allcontent... Or maybe it could be that CSS is repeating:
I had it in code:


I just changed the css like in code example I posted here, and no results.
If someone see where is the catch, please tell.
Thanks!
 
Nicol Green
Ranch Hand
Posts: 66
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Found what is the problem.

I entirely forgot that I have float: right; for the .right
So when I do it without float it works, and with it doesn't work.

Why is this happening and what I can do to make it work ?

Thanks!
 
Nicol Green
Ranch Hand
Posts: 66
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I didn't mention that I am using FF.
I checked now and it is working in IE.

What should I do to start to work in FF as well ?

Thanks
 
Eric Pascarello
author
Posts: 15385
6
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
http://jsbin.com/aboho3/2/edit

All of the links are clickable for me in the code you gave.

Are you able to click the links if you preview the link above?

Eric
 
Nicol Green
Ranch Hand
Posts: 66
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I see. Yes, I am able to click to above links. Thanks!
I also added css for right attribute(with float):

and it is also working. I really cannot figure out why it is not working within my code..
reply
    Bookmark Topic Watch Topic
  • New Topic