Win a copy of The Little Book of Impediments (e-book only) this week in the Agile and Other Processes forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

JNLP Downloading Fail: SSLException: bad record MAC

 
Gurunath Kale
Greenhorn
Posts: 14
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi All

I am getting unable to launch application error while launching my application through webstart.
Application was getting downloaded and running properly previously.
But now I am getting following error on JNLP console.

#### Java Web Start Error:
#### Unable to load resource: https://www.somevalidIP.com/MyClient/jars/ClientModel.jar

The exception is coming while downloading the JARs through webstart, strange thing is everytime the location of exception changing. It means, if my jnlp file has 50 urls for downloading 50 jars, exception location is changing for downloading differant jars.
Is this exception due to some security issue, as at the client side (where there are no network security restriction) the application is getting downloaded and running fine.

Wrapped Exception gives me following details
javax.net.ssl.SSLException: Connection has been shutdown: javax.net.ssl.SSLException: bad record MAC
at com.sun.net.ssl.internal.ssl.SSLSocketImpl.checkEOF(Unknown Source)
at com.sun.net.ssl.internal.ssl.AppInputStream.available(Unknown Source)
at java.io.BufferedInputStream.available(Unknown Source)
at sun.net.www.MeteredStream.available(Unknown Source)
at sun.net.www.http.KeepAliveStream.close(Unknown Source)
at java.io.FilterInputStream.close(Unknown Source)
at sun.net.www.protocol.http.HttpURLConnection$HttpInputStream.close(Unknown Source)
at java.io.BufferedInputStream.close(Unknown Source)
at com.sun.deploy.net.HttpDownloadHelper.download(Unknown Source)
at com.sun.deploy.cache.Cache.downloadResourceToTempFile(Unknown Source)
at com.sun.deploy.cache.Cache.downloadResourceToCache(Unknown Source)
at com.sun.deploy.net.DownloadEngine.actionDownload(Unknown Source)
at com.sun.deploy.net.DownloadEngine.getCacheEntry(Unknown Source)


Has anyone faced such kind of issue. Can anybody help in resolving this? Do I need to change any Websrtart setting for this? I tried some combination but it didn't worked.

Let me know if any more information needed.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic