Win a copy of The Java Performance Companion this week in the Performance forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

JSP not able to find tag library descriptor | Struts 1.3 | Websphere App Server 7.0 | RAD 8.0

 
jazz pal
Greenhorn
Posts: 7
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I'm trying to do a simple hello world struts app (using Struts 1.3) on Websphere App Server 7.1.
The JSP's are not able to find the tag libraries showing the error "Can not find the tag library descriptor for "http://struts.apache.org/tags-logic"
From what I understand
1. With JSP 2 it is not required to mention .tld descriptors in web.xml as structs.jar has it already - This does not seem to the case as I'm getting errors
2. I did enter the web descriptor in web.xml and moved the corresponding tld in the WEB-INF folder - this did not help either.
My web.xml looked like this


My jsp looks like this


Questions
1. Could you help me in understanding how to resolve this issue?
2. Is there any setting which needs to be done for RAD or WAS to configure Struts? All I did was create a dynamic web project, copy libs and created my struts-config.xml and java classes

Thanks
 
jazz pal
Greenhorn
Posts: 7
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Resolved the issue - It was an issue with the web.xml. Sharing the solution with the forum
1. Web.xml needs to mention the location of the tld with the absolute URL instead of relative path as I had put earlier
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic