Win a copy of Cross-Platform Desktop Applications: Using Node, Electron, and NW.js this week in the JavaScript forum!
    Bookmark Topic Watch Topic
  • New Topic

Known issue with glassfish 3.1 during running webservices example  RSS feed

 
Kamal Tripathi
Ranch Hand
Posts: 86
  • Mark post as helpful
  • send pies
  • Report post to moderator
I am using glassfish 3.1 to deploya webservice example from SOA Using Webservices by Mark Hansen.

I got to the part to be able to deploy the webservice, now the TestClient written to test the service is not working. Here is the exception I am getting.



Here is the code from the Client.java which executes it. As you can see issue is because it is not able to get Port definition.



Now I think the issue with jars in glassfish only since.

1. I see the webservice is running when I use it thru soapUI so there is no issue at the server side. I am able to get a good response
2. I also checked the portQName and serviceQName look ok to me.

Also while googling I came across some posts which tell me that this is a known issue with Tomcat (Link1, Link2). To be sure I added endorsed folder and relevant jars in glassfish home as well. But it still isn't working.

I didn't come across anything which points to an issue with glassfish server. So wanted to quickly check if someone might have come across this issue with Glassfish 3.1 as well.

A project has been created for SOA examples which has WSDL hosted so you can refer that as well. Thanks.
 
Bear Bibeault
Author and ninkuma
Marshal
Posts: 66141
141
IntelliJ IDE Java jQuery Mac Mac OS X
  • Mark post as helpful
  • send pies
  • Report post to moderator
Please do not post the same question more than once.
 
    Bookmark Topic Watch Topic
  • New Topic
Boost this thread!