Win a copy of Programmer's Guide to Java SE 8 Oracle Certified Associate (OCA) this week in the OCAJP forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

location.href not working on FireFox 3.5

 
Ankit Chandrawat
Ranch Hand
Posts: 88
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

location.href is not working on FF 3.5,Chrome,safari on line 49 in the included jsp. location.href is working fine with IE 6,7,8.Please guide me.




TIA,
Ankit Chandrawat
 
Bear Bibeault
Author and ninkuma
Marshal
Pie
Posts: 65105
89
IntelliJ IDE Java jQuery Mac Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Please take the time to choose an appropriate forum for your posts. This forum is for questions on JSP. For more information, please click this link ⇒ CarefullyChooseOneForum. This post has been moved to a more appropriate forum.

Also, please be sure to use code tags when posting code to the forums. Unformatted or unindented code is extremely hard to read and many people that might be able to help you will just move along to posts that are easier to read. Please click this link ⇒ UseCodeTags ⇐ for more information.

Properly indented and formatted code greatly increases the probability that your question will get quicker, better answers.

I've added such tags to your post -- see how much easier it is to read?
 
Bear Bibeault
Author and ninkuma
Marshal
Pie
Posts: 65105
89
IntelliJ IDE Java jQuery Mac Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
P.S. Since this is a client-side JavaScript issue, it'd better if you post the rendered HTML rather than the JSP source. (And cut it down to the minimum that shows the problem.)
 
Ankit Chandrawat
Ranch Hand
Posts: 88
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I Will take care of the above mentioned points.Sorry for the inconvenience. The rendered html for the code is


the div is clickable on IE6,7,8 but not on FF,chrome and Safari. I guess there is some problem with CSS property. Please guide me

 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic