• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Bear Bibeault
  • Ron McLeod
  • Jeanne Boyarsky
  • Paul Clapham
Sheriffs:
  • Tim Cooke
  • Liutauras Vilda
  • Junilu Lacar
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • fred rosenberger
  • salvin francis
Bartenders:
  • Piet Souris
  • Frits Walraven
  • Carey Brown

Need help regarding <p>

 
Ranch Hand
Posts: 367
Eclipse IDE Opera Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello,

I need to add "<"p">" (i.e. Paragraph) tag in my xml but am unable to do so.

I tried writing <!CDATA[[ actual code ]]>section but CDATA is under <sc:Section> element and when I try to validate it,
the parser displays this error :-

cvc-complex-type.2.3: Text '"<""p">"Send comments and suggestions to <url protocol="mailto">barchal@pineapplesoft.com</url>."<"p">"' is not allowed for element <sc:section>. The element declaration's content type is 'element-only'.



NOTE: I'm double quoting "<"p">" as it gets removed after posting here. The Schema is well formed and valid, the xml file is well formed only.

I'm using XMLSpy from Altova and when I check for <sc:section> element in it, I get the following details:

minOcc=1, maxOcc=Unbound, Content =Complex. There is nothing like element-only as shown by the error message.

Below is my XML schema


Below is my XML



Please advise.

Thank you.
 
pramod talekar
Ranch Hand
Posts: 367
Eclipse IDE Opera Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I replaced <![CDATA [ ... ]]> with < & > the problem is resolved.
 
Don't get me started about those stupid light bulbs.
    Bookmark Topic Watch Topic
  • New Topic