Win a copy of Pragmatic AI this week in the Artificial Intelligence forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Jeanne Boyarsky
  • Liutauras Vilda
  • Campbell Ritchie
  • Tim Cooke
  • Bear Bibeault
Sheriffs:
  • Paul Clapham
  • Junilu Lacar
  • Knute Snortum
Saloon Keepers:
  • Ron McLeod
  • Ganesh Patekar
  • Tim Moores
  • Pete Letkeman
  • Stephan van Hulst
Bartenders:
  • Carey Brown
  • Tim Holloway
  • Joe Ess

cvc-complex-type.2.1: Element 'soap:address'... WSDL Error in Eclipse  RSS feed

 
Greenhorn
Posts: 8
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi All,

I am integrating my exsting workspace in Eclipse 3.6. This workspace was originally created using BEA Workshop 10.3 and weblogic 9.2 server and was working fine. Now I am using JDK 6 and weblogic 10.3.4 server along with Eclipse. But when I imported this workspace in Ecipse, I am getting below error:

Error 1: Description Resource Path Location Type
cvc-complex-type.2.1: Element 'soap:address' must have no character or element information item [children], because the type's content type is empty.

Error 2: Description Resource Path Location Type
cvc-complex-type.2.1: Element 'soap:binding' must have no character or element information item [children], because the type's content type is empty.

Error 3: Description Resource Path Location Type
The input element is referencing an undefined message 'getTaskByIDRequestMsg'. Check that the message name and namespace are correct and that the message has been defined. AppComponent1INFExport_listComponent1INFHttpService.wsdl /appWebServiceClient/src/myapp/list_new line 2 WSDL Problem

Starting part of one of my WSDL file is :
<wsdl:definitions
xmlns:soapenc="http://schemas.xmlsoap.org/soap/encoding/"
xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap/"
xmlns:wsdl="http://schemas.xmlsoap.org/wsdl/"
xmlns:this="http://Createflow/createflowINF/Binding"
xmlns:Port_0="http://createflow/createflowINF"
xmlns="http://schemas.xmlsoap.org/wsdl/"
name="createflowINFExport1_createflowINFHttp_Service"
targetNamespace="http://Createflow/createflowINF/Binding">

I am unable to figure out the cause of the errors. Can anybody please help me in this. Thanks in advance.
 
It is sorta covered in the JavaRanch Style Guide.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!