• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Paul Clapham
  • Liutauras Vilda
Sheriffs:
  • paul wheaton
  • Rob Spoor
  • Devaka Cooray
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Frits Walraven
  • Tim Moores
Bartenders:
  • Mikalai Zaikin

Problem Installing OpenVPN to Emulator

 
Ranch Hand
Posts: 79
Android Java ME Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

Hello,

I am a newbie on this site and android development. I want to installa nd run openvpn to my emulator. I am using these 2 sites for reference :
1)
chengdu110.wordpress com
2010/08/14
want-openvpn-work-on-android-device
2)
android.modaco
content
software
291919
openvpn-on-android/

I am facing couple of problems. From 1st site, I can't copy busybox to system/xbin folder. I get no access, permission failure, etc such messages. Am stuck at this point and thus can't proceed ahead. In Part 2 also need to access /system/lib/ where again problem comes.

In site 2, same cannot access /system/lib or /system/bin folder. Even I can't mount like this : ADB shell mount /system
Command mount -o rw,remount -t yaffs2 /dev/block/mtdblock3 /system from site 1 was successful.

Even I face problems with cp cmd. Just cp libcrypto.so libcrypto-orig.so doesn't work. I got to give "/system/lib/libcrypto.so cp libcrypto.so libcrypto-orig.so" this format only it copies. Though in the above case "Permission denoed" occured for system/lib. But this foramt worked while copying busybox file.


Can anyone help me with the permission to system folders /xbin, /lib, /bin. Why is mounting required ? Why I am not able to mount directly as mount /system; I need to give full command mount -o rw, .... -t .... /system. I am not sure what all to give in the "..." place - had just copied it from site 1.

Any help, guidance is highly appreciated. I use Eclipse DDMS and Android emulator 2.3.3. Please try to help me.


Thanks
 
Don't get me started about those stupid light bulbs.
reply
    Bookmark Topic Watch Topic
  • New Topic