• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Paul Clapham
  • Bear Bibeault
  • Junilu Lacar
Sheriffs:
  • Jeanne Boyarsky
  • Tim Cooke
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • salvin francis
  • Frits Walraven
Bartenders:
  • Scott Selikoff
  • Piet Souris
  • Carey Brown

Implementing SSL, JAX-WS Webservice IBM websphere JAX-WS runtime

 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Guys,

I am trying to make SSL work on a webservice created by using IBM Websphere JAX-WS runtime for quite a while now but am unable to make it work somehow.

Need your help in resolving the problem.

These are the steps I have taken.

Its a simple Add Numbers Web service which adds two numbers and returns the output.

I deployed the webservice on WAS 7.0

the endpoint for the ws is http://localhost:9080/WebServiceProject/AddNumbersSvc/AddNumbersSvc.wsdl

Than to configure the ssl I took the following steps:


In WAS admin console: Services->Policy Sets->Application Policy Sets. Than I selected WSHTTPS default. copied it and rename it to WS SSL Policy, I dint chnage anything in it.
Next, I went to Security->SSl ceritificate and key management ->Key stores and certificates I created ServerKeyStore with a self signed certificate and ServerTrustStore with the client public key
Than, I went to Security->SSl ceritificate and key management -> SSL Configurations and I created a new configuration WS SSL conf set the trust store as ServerTrustStore and Keystore as ServerKeyStore
Next, I went to QOP setting of WS SSL conf. There I set client authentication as required , protocol as ssl and rest all default.
Than, I went to Services->Policy Sets->General provider policy set bindings. Than I selected WSHTTPS default. copied it and rename it to WS SSL Binding. seleced it. than selected SSL transport and selected WS SSL conf as SSL settings
Finally I went to Services->Service providers. selected AddNumbers service and apllied WS SSL Policy as policy set and WS SSL Binding as Binding.

Now when i restated the application and tried to execute the ws through
https://localhost:9080/WebServiceProject/AddNumbersSvc/AddNumbersSvc.wsdl

i got a 404 and also when i triggered the ws through SOAPUi with http i got the repsonse but not with https.

Please help me to figure out what i did wrong .
 
So there I was, trapped in the jungle. And at the last minute, I was saved by this tiny ad:
Building a Better World in your Backyard by Paul Wheaton and Shawn Klassen-Koop
https://coderanch.com/wiki/718759/books/Building-World-Backyard-Paul-Wheaton
    Bookmark Topic Watch Topic
  • New Topic