Win a copy of The Way of the Web Tester: A Beginner's Guide to Automating Tests this week in the Testing forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

sslext with tiles. URL shows .jsp instead of .do

Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi All,
I am Struts 1.2.8 with Tiles,Velocity Menu & sslext-1.2 .
Problem is :
1. I'm linking from one page to another page with as the following URL with https:
<a href="https://localhost:8443/web/"> SSL</a>
2. That is Action with ".do".
3. struts-config.xml
<action path="/formAction" type="test.ssl.NullAction">
<set-property property="secure" value="false"/>
<forward name="success" path="/form.jsp" />
This is just forward to the required form (form.jsp). So, if we activate hit the URL as http://localhost:8080/web/ - (No https)
the form will show properly (No URL Change)

4.But in form.jsp, if we add the following lines:
<%@ taglib uri="/WEB-INF/StrutsConfig/sslext.tld" prefix="sslext" %>
<sslext ageScheme secure="false"/>

Because the page should be load as non https. Logic is posting of data is https after forawarding to another page is non https.

5. Using https link if we click, moving as security alert, then once again moving to non secured page.
But the URL is
Instead of http://localhost:8080/web/ .

What is the problem how we can resolve this?. Becuse of this is , template based tiles is not working properly.

All Suggestions are welcomes and my advance thanks

This is very urgend. Once again my thanks.

you can reach me

  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic