• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Liutauras Vilda
  • Campbell Ritchie
  • Tim Cooke
  • Bear Bibeault
  • Devaka Cooray
Sheriffs:
  • Jeanne Boyarsky
  • Knute Snortum
  • Junilu Lacar
Saloon Keepers:
  • Tim Moores
  • Ganesh Patekar
  • Stephan van Hulst
  • Pete Letkeman
  • Carey Brown
Bartenders:
  • Tim Holloway
  • Ron McLeod
  • Vijitha Kumara

Client disconnected from server after about 10 minutes of inactivity  RSS feed

 
Ranch Hand
Posts: 495
Chrome Java Linux
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
My client is disconnected from the server after about 10 minutes of inactivity. Why is this? I do not have anything in my code that does that. The program stays up, but the connection between the client and server is lost. Why is this and how can I fix it?
NOTE: My client code is over 1k lines long, so you probably don't want me posting that. It hopefully is just a general problem that can be fixed...
Server code:

Thanks,
cc11rocks aka John Price
 
john price
Ranch Hand
Posts: 495
Chrome Java Linux
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Fine...
Server code:

Would this fix the problem?
 
Sheriff
Posts: 21459
96
Chrome Eclipse IDE Java Windows
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Possibly. The best way to find out is to try it out.
(And I'm not just saying this to avoid giving the answer - I just don't know for sure.)
 
john price
Ranch Hand
Posts: 495
Chrome Java Linux
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I tried it...It didn't work. I found a work-around, but I am sure there is something I can do. I shouldn't have to use the workaround...
The workaround I am doing is setting off a "fake" message to keep it inactive. This will not do when I distribute...
Thanks,
cc11rocks aka John Price
 
john price
Ranch Hand
Posts: 495
Chrome Java Linux
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
BUMP and Change.
I meant to say "to keep it active" instead of "to keep it inactive".
John Price aka cc11rocks
 
john price
Ranch Hand
Posts: 495
Chrome Java Linux
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I had to go into Windows to fix this:
Control Panel > Installed Updated > Turn Windows Features on or Off > (CheckBox) Simple TCPIP services (i.e. echo, daytime etc)
Works like a charm now.
cc11rocks aka John Price
 
It is sorta covered in the JavaRanch Style Guide.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!