• Post Reply Bookmark Topic Watch Topic
  • New Topic

Getting svn error : U...RL access forbidden for unknown reason...svn: Commit failed....  RSS feed

shyam shridhar
Ranch Hand
Posts: 31
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

I'm getting following error while committing the code back to server. If getting below error from eclipse as well as command line. I did google search to find the solution/cause there are many similar issues but not work for me.

I can checkout project there is not such problem at the time of checkout, problem is having only for checkin process.

My project is multi-module maven project:


commit -m "Task completed" D:/mukesh_admin/workspace/boa/webclient/src/test/resources/hibernate.cfg.xml
Sending D:/mukesh_admin/workspace/boa/webclient/src/test/resources/hibernate.cfg.xml
URL access forbidden for unknown reason
svn: Commit failed (details follow):
svn: access to '/svn/repos/!svn/ver/537/boa/webclient/src/test/resources/hibernate.cfg.xml' forbidden

Option i tried are
1) Removed below file(By doing eclipse again asked for username and password). Still not working.

At above path four folder exists svn.simple, svn.ssl.client-passphrase, svn.ssl.server, svn.username.
All folder are empty except svn.simple which have only one file name '398......' content of this file is as follow :-
K 8
V 8
K 8
V 260
SDFSDFSF@#@#@##@#$@#@#$@#@$#@#$@#$@#@#$@#$@#$@#$@# [encypted password: this code was added by me]
K 15
V 60
<https://SvnServerName> Subversion repository
K 8
V 5

2) By comparing server path and local path for case sensitiveness

My Svn Server complete file path upto hibernate.cfg.xml is as follow


3) I asked my senior to see if I have proper access to project on the svn server(though it is not required as I can update project), He said I have required access.

System Details
Window 7(64 bit)
Eclipse Helios Service Release 1
SilkSvn version : 1.6.16 (x64)
Subeclipse Details : image attached

Can you guys please suggest something about above problem, may be anybody of you recently faced it. Is there any otherwise site/forum where I can get help about it.

Sorry if anything unclear because of my english.. still learning...

Thanks guys
[Thumbnail for subeclipse-details.png]
shyam shridhar
Ranch Hand
Posts: 31
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

The problem has been solved by my colleague who manage svn server.

Instead of [repository:path] format , he listed the relative filesystem path. I.e., instead of [repos:/] he had [/repos/].
Problem fixed by modifying Apache config.
It is sorta covered in the JavaRanch Style Guide.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!