Win a copy of Event Streams in Action this week in the Java in General forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Devaka Cooray
  • Liutauras Vilda
  • Jeanne Boyarsky
  • Bear Bibeault
Sheriffs:
  • Paul Clapham
  • Knute Snortum
  • Rob Spoor
Saloon Keepers:
  • Tim Moores
  • Ron McLeod
  • Piet Souris
  • Stephan van Hulst
  • Carey Brown
Bartenders:
  • Tim Holloway
  • Frits Walraven
  • Ganesh Patekar

Eclipse gives error when I try to run the debugger -- "Cannot find a free socket for the debugger"

 
Greenhorn
Posts: 16
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am trying to run eclipse galileo on 32 bits windows 7, everything works fine except the debugger. I tried the following steps as well but it did not work.

Steps I tried:
1")Switched off the Zone Alarm Firewall
2) Switched off my Norton Internet Security suite
3) Switched off the UAC
4) Started eclipse with"Run as an Administrator" option

I got the following error trace.

Error trace:
eclipse.buildId=unknown
java.version=1.6.0_25-ea
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
Framework arguments: -product org.eclipse.epp.package.jee.product
Command-line arguments: -os win32 -ws win32 -arch x86 -product org.eclipse.epp.package.jee.product


Error
Mon May 02 16:23:16 IST 2011
Cannot find a free socket for the debugger


-------------------------------
I also tried re-installing Eclipse. This time I installed Eclipse Helios SR-1. I tested debugging my project, it worked. We use SVN as repository in my company. So I went ahead and installed the SVN plugins and connector. After linking the code to SVN, if I try to run my debugger now, I get the same error back "cannot find a free socket for debugger".

Any help would be appreciated

Thanks in advance
Pooja
 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I think this will work:
- open CMD as an Admin and type this : Netsh winsock reset
This was the only way that worked for me.
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!