This week's book giveaway is in the Android forum.
We're giving away four copies of Head First Android and have David & Dawn Griffiths on-line!
See this thread for details.
Win a copy of Head First Android this week in the Android forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Tim Cooke
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Liutauras Vilda
Sheriffs:
  • Jeanne Boyarsky
  • Rob Spoor
  • Bear Bibeault
Saloon Keepers:
  • Jesse Silverman
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
Bartenders:
  • Piet Souris
  • Al Hobbs
  • salvin francis

Getting error 400 - Proxy Error: remote host didn't send any data.

 
Greenhorn
Posts: 20
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi All,

I am getting Error 400 - Proxy Error: remote host didn't send any data.

In our application, we can download files by clicking on download link which has 2 options.
i.e. 1. download by excel
2. download by ODS format (Open document spreadsheet).

When the file size is lesser, then both the download option is working fine.
When the file size is huge (greater than 60 MB), then download by excel works fine, but download by ODS format doesn't work.

The above scenario is happening only in UAT (User Acceptance test) environment. But same code is working fine for all the scenarios in DEV and SIT (System Integration) environment.

From implementation point of view:

In excel, we write data directly to the output stream response object which will collected as text/excel.
In ODS format, we create 5 xml files and write the respective data to those file and then zip them and send the zip file to output stream response object.

Is this error 400, because its getting response timed out?

Please let me know how to fix this issue.

Thanks,
Chinnu.
 
reply
    Bookmark Topic Watch Topic
  • New Topic