Win a copy of The Journey To Enterprise Agility this week in the Agile and Other Processes forum! And see the welcome thread for 20% off.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Jeanne Boyarsky
  • Liutauras Vilda
  • Campbell Ritchie
  • Tim Cooke
  • Bear Bibeault
Sheriffs:
  • Paul Clapham
  • Junilu Lacar
  • Knute Snortum
Saloon Keepers:
  • Ron McLeod
  • Ganesh Patekar
  • Tim Moores
  • Pete Letkeman
  • Stephan van Hulst
Bartenders:
  • Carey Brown
  • Tim Holloway
  • Joe Ess

Cant look up from one deployment to another.  RSS feed

 
Ranch Hand
Posts: 79
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

I am using weblogic 11g, Ejb3.0

Problem is that I cant see the jndi tree in the weblogic console. And more over I cant do look up from one deployment ear to another
.

I am running the weblogic locally from MyEclipse.


My JNDI tree fro some reason via the console doesnt show my EJBS.

Now this is how my stateless been which I am trying to look up into looks like: (I tried variouse things)

@CallByReference
@Local ({SyncOperatorsBeanLocal.class})
@Remote ({SyncOperatorsBeanRemote.class})
@Stateless(mappedName = "SyncOperatorsBean")
@JNDIName("ejb/SyncOperatorsBean")
public class SyncOperatorsBean implements SyncOperatorsBeanLocal,SyncOperatorsBeanRemote
public void executeSyncOperation()
{
}
{
..
}

And this is the Joline I am executing from my job class in order to run the SyncOperatorsBean.executeSyncOperation


SyncOperatorsBeanRemote SyncOperatorsBean = (SyncOperatorsBeanRemote) context
.lookup("SyncOperatorsBean#com.mirs.sbngenerate.beans.SyncOperatorsBeanRemote");

SyncOperatorsBean.executeSyncOperation();


Now that’s the exception:

javax.naming.NameNotFoundException: While trying to lookup 'SyncOperatorsBean#com.mirs.sbngenerate.beans.SyncOperatorsBeanRemote' didn't find subcontext 'SyncOperatorsBean#com'. Resolved ''; remaining name 'SyncOperatorsBean#com/mirs/sbngenerate/beans/SyncOperatorsBeanRemote'
at weblogic.jndi.internal.BasicNamingNode.newNameNotFoundException(BasicNamingNode.java:1139)
at weblogic.jndi.internal.BasicNamingNode.lookupHere(BasicNamingNode.java:247)
at weblogic.jndi.internal.ServerNamingNode.lookupHere(ServerNamingNode.java:182)
at weblogic.jndi.internal.BasicNamingNode.lookup(BasicNamingNode.java:206)
at weblogic.jndi.internal.WLEventContextImpl.lookup(WLEventContextImpl.java:254)
at weblogic.jndi.internal.WLContextImpl.lookup(WLContextImpl.java:393)
at com.mirs.ecms.timer.StartSyncJob.execute(StartSyncJob.java:63)
at org.quartz.core.JobRunShell.run(JobRunShell.java:216)
at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:549)





thanks,
ray.





 
ray frid
Ranch Hand
Posts: 79
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have added @JNDIName("ejb/SyncOperatorsBean") to the bean SyncOperatorsBean. and it solved the JNDI TREE prob. I can see it there. but I still can do look up.
same error.

any idea?
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!