• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Paul Clapham
  • Rob Spoor
  • Liutauras Vilda
Sheriffs:
  • Jeanne Boyarsky
  • Junilu Lacar
  • Tim Cooke
Saloon Keepers:
  • Tim Holloway
  • Piet Souris
  • Stephan van Hulst
  • Tim Moores
  • Carey Brown
Bartenders:
  • Frits Walraven
  • Himai Minh

Getting error while upgrading my running application from jboss-4.2.1.GA to jboss-6.0.0.Final.

 
Greenhorn
Posts: 8
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator


Actually my application is running successfully in jboss-4.2.1.GA, but now i have to upgrade it on jboss-6.0.0.Final. I just copy my running .ear file at jboss-6.0.0.Final\server\default\deploy\ and trying to run it.
 
Sheriff
Posts: 10445
227
IntelliJ IDE Ubuntu
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
XML validation in JBoss AS 5 and JBoss AS 6 is stricter than what it used to be in JBoss AS 4.x. Your web.xml seems to have an incorrect entry (the order matters) as compared to what is expected by the xsd. Use a xml validating editor or check the xsd to fix the problem. The exception stacktrace is telling you exactly which line and which element in the web.xml is incorrect.
 
anil kumar khichar
Greenhorn
Posts: 8
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Thanks Jaikiran!

I rechecked my web.xml against xml validator editor. XML is perfect but its ordering according to new jboss-6.0.0.Final xsd's seems incorrect.

Will you please guide me from where i can set xsd's setting i.e the xsd version which should be checked while parsing web.xml. It may be some jboss settings xml.

Whether should i change my web.xml ordering what the new xsd expecting or change somehow the settings of xsd's to the previous one which was checked while in jboss-4.x.As my application was running perfectly in jboss-4.x.

Below is my web.xml :-

<?xml version="1.0" encoding="ISO-8859-1"?>

<web-app>
<display-name>My Application Name</display-name>

<!-- RED 5 Server Configuration -->
<context-param>
<param-name>globalScope</param-name>
<param-value>default</param-value>
</context-param>

<context-param>
<param-name>parentContextKey</param-name>
<param-value>default.context</param-value>
</context-param>

<context-param>
<param-name>contextConfigLocation</param-name>
<param-value>/WEB-INF/applicationContext.xml, /WEB-INF/red5-common.xml, /WEB-INF/red5-core.xml, /WEB-INF/*-context.xml</param-value>
</context-param>

<listener>
<listener-class> org.springframework.web.util.Log4jConfigListener</listener-class>
</listener>

<listener>
<!-- Impersonates a org.springframework.web.context.ContextLoaderListener -->
<listener-class>org.red5.server.MainServlet</listener-class>
</listener>

<listener>
<listener-class>org.springframework.web.context.request.RequestContextListener</listener-class>
</listener>

<servlet>
<servlet-name>gateway</servlet-name>
<servlet-class> org.red5.server.net.servlet.AMFGatewayServlet</servlet-class>
<load-on-startup>1</load-on-startup>
</servlet>

<servlet>
<servlet-name>rtmpt</servlet-name>
<servlet-class> org.red5.server.net.rtmpt.RTMPTServlet </servlet-class>
<load-on-startup>2</load-on-startup>
</servlet>

<servlet-mapping>
<servlet-name>gateway</servlet-name>
<url-pattern>/gateway</url-pattern>
</servlet-mapping>

<servlet-mapping>
<servlet-name>rtmpt</servlet-name>
<url-pattern>/rtmpt</url-pattern>
</servlet-mapping>

<security-constraint>
<web-resource-collection>
<web-resource-name>Forbidden</web-resource-name>
<url-pattern>/WEB-INF/*</url-pattern>
</web-resource-collection>
<auth-constraint/>
</security-constraint>

<security-constraint>
<web-resource-collection>
<web-resource-name>Forbidden</web-resource-name>
<url-pattern>/persistence/*</url-pattern>
</web-resource-collection>
<auth-constraint/>
</security-constraint>

<security-constraint>
<web-resource-collection>
<web-resource-name>Forbidden</web-resource-name>
<url-pattern>/streams/*</url-pattern>
</web-resource-collection>
<auth-constraint/>
</security-constraint>

<!-- End of Red 5 Server configuration-->

<!--My Application Configuration -->
<filter>
<filter-name>SystemLockFilter</filter-name>
<filter-class> com.myapplication.settings.SystemLockFilter </filter-class>
</filter>

<filter-mapping>
<filter-name>SystemLockFilter</filter-name>
<url-pattern>*.do</url-pattern>
</filter-mapping>

<!-- Standard Action Servlet Configuration 1.2 (with debugging) -->
<servlet>
<servlet-name>action</servlet-name>
<servlet-class> org.apache.struts.action.ActionServlet </servlet-class>
<init-param>
<param-name>config</param-name>
<param-value>/WEB-INF/struts-config.xml</param-value>
</init-param>
<init-param>
<param-name>debug</param-name>
<param-value>2</param-value>
</init-param>
<init-param>
<param-name>detail</param-name>
<param-value>2</param-value>
</init-param>
<load-on-startup>3</load-on-startup>
</servlet>
<servlet>
<servlet-name>LoadConfig</servlet-name>
<servlet-class>com.myapplication.login.LoadConfig</servlet-class>
<load-on-startup>4</load-on-startup>
</servlet>
<servlet>
<servlet-name>VersionSynchronizeServlet</servlet-name>
<servlet-class>com.myapplication.settings.VersionSynchronizeServlet</servlet-class>
<load-on-startup>5</load-on-startup>
</servlet>

<servlet>
<servlet-name>ScheduleServlet</servlet-name>
<servlet-class>com.myapplication.schedule.ScheduleServlet</servlet-class>
<load-on-startup>6</load-on-startup>
</servlet>

<servlet>
<servlet-name>Download</servlet-name>
<servlet-class>com.myapplication.player.Download</servlet-class>
</servlet>
<servlet-mapping>
<servlet-name>Download</servlet-name>
<url-pattern>/Download</url-pattern>
</servlet-mapping>
<servlet>
<servlet-name>TakePicture</servlet-name>
<servlet-class>commyapplication.player.TakePicture</servlet-class>
</servlet>
<servlet-mapping>
<servlet-name>TakePicture</servlet-name>
<url-pattern>/TakePicture</url-pattern>
</servlet-mapping>
<servlet>
<servlet-name>StreamServlet</servlet-name>
<servlet-class>com.myapplication.player.StreamServlet</servlet-class>
</servlet>
<servlet-mapping>
<servlet-name>StreamServlet</servlet-name>
<url-pattern>/StreamServlet</url-pattern>
</servlet-mapping>
<servlet>
<servlet-name>DownloadServlet</servlet-name>
<servlet-class>com.myapplication.rss.DownloadServlet</servlet-class>
</servlet>
<servlet-mapping>
<servlet-name>DownloadServlet</servlet-name>
<url-pattern>/DownloadServlet</url-pattern>
</servlet-mapping>

<!--Used for Struts 2-->
<filter>
<filter-name>struts2</filter-name>
<filter-class> org.apache.struts2.dispatcher.FilterDispatcher
</filter-class>
</filter>
<filter-mapping>
<filter-name>struts2</filter-name>
<url-pattern>*.action</url-pattern>
</filter-mapping>
<!--End of Struts 2-->

<!-- Standard Action Servlet Mapping -->
<servlet-mapping>
<servlet-name>action</servlet-name>
<url-pattern>*.do</url-pattern>
</servlet-mapping>

<!-- The Usual Welcome File List -->
<welcome-file-list>
<welcome-file>login.jsp</welcome-file>
</welcome-file-list>

<security-constraint>
<display-name>Secure My Application</display-name>
<web-resource-collection>
<web-resource-name>Protected URL</web-resource-name>
<!-- Define the context-relative URL(s) to be protected -->
<url-pattern>/login.jsp</url-pattern>
<url-pattern>/login.do</url-pattern>
<url-pattern>/forgetPassword.do</url-pattern>
<url-pattern>/forgetAnswer.do</url-pattern>
<url-pattern>/bulkupload.do</url-pattern>
<url-pattern>/manageUser.do</url-pattern>
<url-pattern>/backupRestore.do</url-pattern>
<url-pattern>/sysSettings.do</url-pattern>
<url-pattern>/addDomain.action</url-pattern>
<url-pattern>/editDomain.action</url-pattern>
<url-pattern>/saveDomain.action</url-pattern>
<url-pattern>/testSystemLDAPConnection.action</url-pattern>
<http-method>GET</http-method>
<http-method>POST</http-method>
</web-resource-collection>
<user-data-constraint>
<description>SSL ENABLE</description>
<transport-guarantee>CONFIDENTIAL</transport-guarantee>
</user-data-constraint>
</security-constraint>

<!-- Struts Tag Library Descriptors -->
<taglib>
<taglib-uri>/struts-bean</taglib-uri>
<taglib-location>/WEB-INF/struts-bean.tld</taglib-location>
</taglib>

<taglib>
<taglib-uri>/struts-html</taglib-uri>
<taglib-location>/WEB-INF/struts-html.tld</taglib-location>
</taglib>

<taglib>
<taglib-uri>/struts-logic</taglib-uri>
<taglib-location>/WEB-INF/struts-logic.tld</taglib-location>
</taglib>

<taglib>
<taglib-uri>/struts-nested</taglib-uri>
<taglib-location>/WEB-INF/struts-nested.tld</taglib-location>
</taglib>

<taglib>
<taglib-uri>/struts-tiles</taglib-uri>
<taglib-location>/WEB-INF/struts-tiles.tld</taglib-location>
</taglib>
</web-app>
 
anil kumar khichar
Greenhorn
Posts: 8
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Resolved......The error was due to improper sequnce of tags. According to http://java.sun.com/xml/ns/javaee/web-app_2_5.xsd, the web.xml tags sequence should be as :


After changing the sequence i got another one error which was due to <taglib></taglib> tag. According to xsd it should be as :



Finally it's resolved. Thanks coderanch.....
 
Do not meddle in the affairs of dragons - for you are crunchy and good with ketchup. Crunchy tiny ad:
the value of filler advertising in 2021
https://coderanch.com/t/730886/filler-advertising
reply
    Bookmark Topic Watch Topic
  • New Topic