• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Jeanne Boyarsky
  • Devaka Cooray
  • Paul Clapham
Sheriffs:
  • Tim Cooke
  • Knute Snortum
  • Bear Bibeault
Saloon Keepers:
  • Ron McLeod
  • Tim Moores
  • Stephan van Hulst
  • Piet Souris
  • Ganesh Patekar
Bartenders:
  • Frits Walraven
  • Carey Brown
  • Tim Holloway

Eclipse 3.2.2 TomCat Image Cache Problem

 
Greenhorn
Posts: 7
MyEclipse IDE Tomcat Server Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi

I am using Eclipse 3.2.2 and TomCat 5.5 to set up my local web environment. However whenever I start server from the eclipse in "localhost" its keep caching the images. If I change the image with the same name it does not recognise the new coming jpg. Keep showing the old image although I have deleted it from the file system.

Is there anyway to refresh this kind of cache? How can I possibly see the new image with the same exact name?

Any help will be useful..

Thanks
 
Rico Rockbraker
Greenhorn
Posts: 7
MyEclipse IDE Tomcat Server Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Any ideas? )
 
Bartender
Posts: 20836
125
Android Eclipse IDE Tomcat Server Redhat Java Linux
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Tomcat does not cache. It's your browser that does the caching.
 
Rico Rockbraker
Greenhorn
Posts: 7
MyEclipse IDE Tomcat Server Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Tim

True TomCat does not cache...Its the Eclipse I am referring actually?

I am pretty sure its not the browser as I had tried deleting the cache in both chrome and firefox or IE.

Any other ideas?

Thanks for the reply.



 
Greenhorn
Posts: 1
Mac OS X Eclipse IDE Oracle
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello Rico

Try to delete the catalina under your tomcat

 
It is sorta covered in the JavaRanch Style Guide.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!