Win a copy of Kotlin in Action this week in the Kotlin forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

Using AJAX push with ICEfaces (ICEpush)  RSS feed

 
Paolo Pinkel
Ranch Hand
Posts: 35
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I'm using ICEfaces with ICEpush to push some data to the browser.

However, it does not work like planned: It does no AJAX, it just invokes the action and returns from the action like any other non-AJAX action does.

I'm using the newest ICEfaces and ICEpush versions and Tomahawk 7 and JSF 2.

It works with neither Servlet 2.5 nor Servlet 3.0.

These are the important parts of my bean (view scoped):


And this is a snippet of my form:


Did I miss something? Thanks!
 
Guy deLyonesse
Ranch Hand
Posts: 200
Eclipse IDE Java Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Why wouldn't it behave like any other action when it's running in the same thread?
 
Paolo Pinkel
Ranch Hand
Posts: 35
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
It's supposed to do some AJAX magic.

http://wiki.icefaces.org/display/ICE/Easy+Ajax+Push

Or am I understand it wrong? Please correct me, if so.
 
Guy deLyonesse
Ranch Hand
Posts: 200
Eclipse IDE Java Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Compare lines 2 and 8 in your code above.
 
Paolo Pinkel
Ranch Hand
Posts: 35
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I don't get it. What do you mean?

Do you mean the Java code? I don't see anything conspicuous.

Thanks for helping!
 
Guy deLyonesse
Ranch Hand
Posts: 200
Eclipse IDE Java Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
PUSH_GROUP vs PUSH GROUP
 
Paolo Pinkel
Ranch Hand
Posts: 35
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I don't see "PUSH GROUP" anywhere. :O
 
Guy deLyonesse
Ranch Hand
Posts: 200
Eclipse IDE Java Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
OK nevermind. The way it's displaying on my screen the _ character isn't visible in the second occurrence. When I copy/paste it into notepad it's there.

My mistake.
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!