This week's book giveaway is in the Other Languages forum.
We're giving away four copies of Functional Reactive Programming and have Stephen Blackheath and Anthony Jones on-line!
See this thread for details.
Win a copy of Functional Reactive Programming this week in the Other Languages forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

query regarding Ant 'Exec' task

 
Ravinderjit Singh
Ranch Hand
Posts: 78
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi All,

I have prepare an Ant task to start the Tomcat Server, which is working fine.

But I never get the message like 'BUILD SUCCESSFUL' even when Server starts successfully.

Can you please let me know what should I add to get it?



Place the build.xml along with 'startup.bat' and run the ant script like

 
James Sabre
Ranch Hand
Posts: 781
Java Netbeans IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You probably need
fork="true"
as an attribute of the exec .
 
Ravinderjit Singh
Ranch Hand
Posts: 78
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have looked at the Ant Manual, Exec doesn't support 'fork' attribute.

But still I tried, its not working, may be I didn't get the right syntax.

 
James Sabre
Ranch Hand
Posts: 781
Java Netbeans IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Ravinderjit Singh wrote:I have looked at the Ant Manual, Exec doesn't support 'fork' attribute.

But still I tried, its not working, may be I didn't get the right syntax.



Looks like the 'exec' task uses 'spawn' instead of 'fork'! Since I have never started Tomcat this way I can't guarantee this will work; it is just one of the things I would try first.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic