• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Rob Spoor
  • Tim Cooke
  • Junilu Lacar
Sheriffs:
  • Henry Wong
  • Liutauras Vilda
  • Jeanne Boyarsky
Saloon Keepers:
  • Jesse Silverman
  • Tim Holloway
  • Stephan van Hulst
  • Tim Moores
  • Carey Brown
Bartenders:
  • Al Hobbs
  • Mikalai Zaikin
  • Piet Souris

Parameters appears null on server

 
Greenhorn
Posts: 6
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I am using EJB Provider for axis2. I am trying to access my web service through browser by passing parameter as

http://localhost:8080/..../..../methodName?param1="xyz"&param2="abc" but all my parameters appear null on server.

i don't know why this is happening though my web service is running fine for a SOAP call.
if anybody can help...
Thanks in advance...

 
Author and all-around good cowpoke
Posts: 13078
6
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
If your server is an Axis2 SOAP server, why do you expect it to respond to a plain GET?

In theory, a WSDL 2 style server can be set up for a RESTful interface - is that what you are trying to do?

Bill
 
Arpit Gupta
Greenhorn
Posts: 6
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
yes, My server can handle soap and rest both.
in fact i have one service which is accessed on soap and rest fine. but one that is based on EJB is creating problems.
 
reply
    Bookmark Topic Watch Topic
  • New Topic