• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Bear Bibeault
  • Devaka Cooray
  • Liutauras Vilda
  • Jeanne Boyarsky
Sheriffs:
  • Knute Snortum
  • Junilu Lacar
  • paul wheaton
Saloon Keepers:
  • Ganesh Patekar
  • Frits Walraven
  • Tim Moores
  • Ron McLeod
  • Carey Brown
Bartenders:
  • Stephan van Hulst
  • salvin francis
  • Tim Holloway

IE9 and JSESSIONID  RSS feed

 
Greenhorn
Posts: 17
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Tomcat comes standard with examples, one is known as the Number Guessing example:

Try it here : http://admin.jsn-server5.com/jsp-examples/num/numguess.jsp

First try it in Chrome and note your score:
and then in IE9.

How does one make this application work in IE9 ???

Lowering the security levels in IE9 helps, but.....


Thanks/




 
Bartender
Posts: 4089
54
Chrome Fedora Hibernate
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I haven't tried this my self nor used IE9. But what is the kind of security you had to loosen here?
 
wayne forrest
Greenhorn
Posts: 17
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I can not remember exactly: try this though:

Settings-->Privacy-->Advanced

"tick" "Override automatic cookie handling" :
Allow Third Party and First Party cookies is also ticked.

Hope that helps: I do remember that the problem was that session variables were not saved / persist on subsequent requests.

 
Vijitha Kumara
Bartender
Posts: 4089
54
Chrome Fedora Hibernate
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Are you saying that the application does not fall back to URL rewriting if the cookies are disabled?
 
wayne forrest
Greenhorn
Posts: 17
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am not sure. One will have to test this.
 
Vijitha Kumara
Bartender
Posts: 4089
54
Chrome Fedora Hibernate
  • Likes 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Yep, once you disabled the cookies it won't work as expected.
 
wayne forrest
Greenhorn
Posts: 17
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have finally resolved this

Seems that if you do not *encode* your urls, the server will not revert back to URL rewriting.

For example:

Should resolve the problem, best of luck.








 
Vijitha Kumara
Bartender
Posts: 4089
54
Chrome Fedora Hibernate
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Glad you solved it
 
It is sorta covered in the JavaRanch Style Guide.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!