• Post Reply Bookmark Topic Watch Topic
  • New Topic

JSP Include doesn't work  RSS feed

 
Srikant Venkata
Greenhorn
Posts: 19
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Folks,
I have an issue with JSP Include in an application which was coded some 7-8 years back where even javascript and html tags are embedded inside an out.println() syntax.

I am trying to include a banner using this syntax <jsp:include page="Banner.jsp"/> before the place where my <html> tag starts. But unfortunately, this banner doesn't gets picked up.

Whats the best way to make this inclusion of banner work?

-Regards
Srikant Mantha
 
Bear Bibeault
Author and ninkuma
Marshal
Posts: 65833
134
IntelliJ IDE Java jQuery Mac Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Use the correct path to the included file.
 
Srikant Venkata
Greenhorn
Posts: 19
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Well, Adding more explanation. There are 6 tabbed panes, The banner gets displayed on all the first 3 tabbed panes, but when I click on the 4th tabbed pane. I dnt see the banner. The path provided for the included JSP is absolutely correct and works fine with other 3 tabbed panes.
 
Shanky Sohar
Ranch Hand
Posts: 1051
Eclipse IDE Firefox Browser
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
is it specific to some browser...

which technologies you are using like only html or js...

more details....then only we can help///
 
Srikant Venkata
Greenhorn
Posts: 19
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
We use only IE 8, Hence the issue is restricted to IE 8.
Technology wise, we use Java, Oracle, Servlets, JSP, Html, Javascripts and CSS.
 
Shanky Sohar
Ranch Hand
Posts: 1051
Eclipse IDE Firefox Browser
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
if you are using CSS...

Then please try to configure the div box in which you are putting the <jsp:include> with postion attribute.

Your problem should be solved..
 
Shanky Sohar
Ranch Hand
Posts: 1051
Eclipse IDE Firefox Browser
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
And one more thing..
Welcome to JavaRanch...
 
Srikant Venkata
Greenhorn
Posts: 19
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The page had more than 2000 lines of code, due to which the Banner was not getting loaded.
The Page directive attribute <%@page buffer="2kb"%>, helped to display the included banner.

Thanks to all for the suggestion and thoughts

-Regards
Srikant
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!