Win a copy of The Java Performance Companion this week in the Performance forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

properties-maven-plugin-1.0.jar plugin's descriptor contains the wrong version: 1.0-SNAPSHOT

 
sam White
Ranch Hand
Posts: 229
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello,

I am having the following maven error in Eclipse, but running mvn compile war:war in commandline does not have any error.

Here I attached a snapshot of the error in my post.

Thank you in advance for any help.

Thanks
Sam
error.PNG
[Thumbnail for error.PNG]
 
Peter Johnson
author
Bartender
Posts: 5852
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Where do you have the remote repositories defined? In your pom.xml or in settings.xml? And which settings.xml, the one in the Maven directory or the one in ~/.m2? It appears that wherever you have it set, the Maven embedded within Eclipse is not using that same configuration and thus not finding the CodeHaus snapshot repository.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic