• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Tim Cooke
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Liutauras Vilda
Sheriffs:
  • Rob Spoor
  • Junilu Lacar
  • paul wheaton
Saloon Keepers:
  • Stephan van Hulst
  • Tim Moores
  • Tim Holloway
  • Carey Brown
  • Scott Selikoff
Bartenders:
  • Piet Souris
  • Jj Roberts
  • fred rosenberger

version 1.4.2_03 of the jvm is not suitable for this product. 1.5 or greater is required problem

 
Ranch Hand
Posts: 35
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Today i installed windows xp 2002 service pack2, eclipse was working fine on previous same window but now when i run eclipse it gives "version 1.4.2_03 is not suitable for this product.1.5 or greater is required" message and does not run. For checking my version of jvm, i visited java.com and clicked upon free java download button, it verified that i am having recommended java installed(1.6.0_27-ea) but eclipse is giving above mentioned message.Kindly tell me that what should i do?

Thanks in advance
 
Java Cowboy
Posts: 16084
88
Android Scala IntelliJ IDE Spring Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Do you maybe have Oracle database software installed on your system? Some versions come included with a Java 1.4 JRE. Maybe Eclipse is picking that up instead of your Java 6 JRE.

When you type java -version on the command line, then what version does it show?

Modify your PATH environment variable so that Java 6 is first in the PATH, before any Java 1.4 installation.
 
Sheriff
Posts: 22656
126
Eclipse IDE Spring VI Editor Chrome Java Windows
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

Jesper de Jong wrote:Do you maybe have Oracle database software installed on your system? Some versions come included with a Java 1.4 JRE.


Or worse, a Java 1.3 JRE...
 
Ranch Hand
Posts: 160
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Can you go into Eclipse's preferences, like you can in NetBeans, and see which directory and packages are registered with Java (SE I assume?)?
reply
    Bookmark Topic Watch Topic
  • New Topic