version 1.4.2_03 of the jvm is not suitable for this product. 1.5 or greater is required problem
Post by:Adnan Gondal
, Ranch Hand
Today i installed windows xp 2002 service pack2, eclipse was working fine on previous same window but now when i run eclipse it gives "version 1.4.2_03 is not suitable for this product.1.5 or greater is required" message and does not run. For checking my version of jvm, i visited java.com and clicked upon free java download button, it verified that i am having recommended java installed(1.6.0_27-ea) but eclipse is giving above mentioned message.Kindly tell me that what should i do?
Thanks in advance
Post by:Jesper de Jong
Do you maybe have Oracle database software installed on your system? Some versions come included with a Java 1.4 JRE. Maybe Eclipse is picking that up instead of your Java 6 JRE.
When you type java -version on the command line, then what version does it show?
Modify your PATH environment variable so that Java 6 is first in the PATH, before any Java 1.4 installation.
Post by:Rob Spoor
Jesper de Jong wrote:Do you maybe have Oracle database software installed on your system? Some versions come included with a Java 1.4 JRE.
Or worse, a Java 1.3 JRE...
Post by:Walter Gabrielsen Iii
, Ranch Hand
Can you go into Eclipse's preferences, like you can in NetBeans, and see which directory and packages are registered with Java (SE I assume?)?