[Logo]
Forums Register Login
version 1.4.2_03 of the jvm is not suitable for this product. 1.5 or greater is required problem
Today i installed windows xp 2002 service pack2, eclipse was working fine on previous same window but now when i run eclipse it gives "version 1.4.2_03 is not suitable for this product.1.5 or greater is required" message and does not run. For checking my version of jvm, i visited java.com and clicked upon free java download button, it verified that i am having recommended java installed(1.6.0_27-ea) but eclipse is giving above mentioned message.Kindly tell me that what should i do?

Thanks in advance
Do you maybe have Oracle database software installed on your system? Some versions come included with a Java 1.4 JRE. Maybe Eclipse is picking that up instead of your Java 6 JRE.

When you type java -version on the command line, then what version does it show?

Modify your PATH environment variable so that Java 6 is first in the PATH, before any Java 1.4 installation.
 

Jesper de Jong wrote:Do you maybe have Oracle database software installed on your system? Some versions come included with a Java 1.4 JRE.


Or worse, a Java 1.3 JRE...
Can you go into Eclipse's preferences, like you can in NetBeans, and see which directory and packages are registered with Java (SE I assume?)?
Why fit in when you were born to stand out? - Seuss. Tiny ad:
Thread Boost - a very different sort of advertising
https://coderanch.com/t/674455/Thread-Boost-feature


This thread has been viewed 8357 times.

All times above are in ranch (not your local) time.
The current ranch time is
Apr 22, 2018 16:23:29.