• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Tim Cooke
  • Liutauras Vilda
  • Jeanne Boyarsky
Sheriffs:
  • Paul Clapham
  • Rob Spoor
  • Junilu Lacar
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Piet Souris
  • Carey Brown
Bartenders:

The matching wildcard is strict, but no declaration can be found for element 'authentication-provide

 
Ranch Hand
Posts: 183
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I have the following header defined for adding Spring security. I get the following compile time exception but the application runs fine.

Do I have to do any settings for the IDE to understand the definitions. All the other Spring configuration files work fine.

Failed to read schema document ‘http://www.springframework.org/schema/security/spring-security-2.0.1.xsd’

cvc-complex-type.2.4.c: The matching wildcard is strict, but no declaration can be found for element 'authentication-provider'. applicationContext-security.xml spring-security-samples-tutorial-2.0.4/WebContent/WEB-INF line 57 XML Problem

cvc-complex-type.2.4.c: The matching wildcard is strict, but no declaration can be found for element 'global-method-security'. applicationContext-security.xml spring-security-samples-tutorial-2.0.4/WebContent/WEB-INF line 19 XML Problem

cvc-complex-type.2.4.c: The matching wildcard is strict, but no declaration can be found for element 'http'. applicationContext-security.xml spring-security-samples-tutorial-2.0.4/WebContent/WEB-INF line 25 XML Problem
 
ranger
Posts: 17347
11
Mac IntelliJ IDE Spring
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I replied to your other thread.

Do you want me to close the other thread and use this one instead, or close this one and continue in the other thread?

Thanks

Mark
 
Jay Abrahm
Ranch Hand
Posts: 183
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Thanks, that fixed it.

I had made a lot of changes in the XML preferences (XML Schema File Settings, DTD, ...) a long time ago. I have reverted that and it worked. Just didn't know where to look.
 
reply
    Bookmark Topic Watch Topic
  • New Topic