• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Bear Bibeault
  • Paul Clapham
  • Jeanne Boyarsky
Sheriffs:
  • Devaka Cooray
  • Junilu Lacar
  • Tim Cooke
Saloon Keepers:
  • Tim Moores
  • Ron McLeod
  • Tim Holloway
  • Claude Moore
  • Stephan van Hulst
Bartenders:
  • Winston Gutkowski
  • Carey Brown
  • Frits Walraven

Module Rampart in Tomcat ClassNotFoundException  RSS feed

 
Greenhorn
Posts: 7
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi guys, I tried to deploy the rampart module in Tomcat and I face this error:



I search this class and I found in apache-tomcat-7.0.12\webapps\axis2\WEB-INF\lib\axis2-kernel-1.6.0.jar

My versions:
rampart-1.6.0
apache-tomcat-7.0.12
axis2-1.6.0

My steps:
1. I copied all jar from rampart-1.6.0\lib to apache-tomcat-7.0.12\webapps\axis2\WEB-INF\lib\
2. I copied the rampart-1.6.0.mar to apache-tomcat-7.0.12\webapps\axis2\WEB-INF\modules

But I tried start tomcat, the same error alway appear:


What am I doing wrong?

Thanks!
 
Greenhorn
Posts: 6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Seems correct to me I did the same thing this morning.
have you tried getting a new version of rampart in case your download was corrupt?
or maybe it is your tomcat which is having problems?

or you could un-deploy axis2 and try again from scratch it is a quick process anyway.

have you had normal insecure web services running on axis already?
 
The first person to drink cow's milk. That started off as a dare from this tiny ad:
ScroogeXHTML 8.2 - easy to use RTF to HTML converter library
https://coderanch.com/t/707504/ScroogeXHTML-RTF-HTML-XHTML-converter
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!