• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Jeanne Boyarsky
  • Devaka Cooray
  • Paul Clapham
Sheriffs:
  • Tim Cooke
  • Knute Snortum
  • Bear Bibeault
Saloon Keepers:
  • Ron McLeod
  • Tim Moores
  • Stephan van Hulst
  • Piet Souris
  • Ganesh Patekar
Bartenders:
  • Frits Walraven
  • Carey Brown
  • Tim Holloway

Is mod_jk.so binary for Apache 2.2.14 included with apt-get install of apache2 ?

 
Ranch Hand
Posts: 206
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello,

The http://tomcat.apache.org/connectors-doc/miscellaneous/faq.html says that mod_jk.so "works well with Apache 2.2".

It says that you need to download the binary module compiled for version 2.2. On Ubuntu 10.04 (32-bit) in the /usr/lib/apache2/modules directory, there are (3) important files, i.e. mod_proxy_ajp.so, mod_proxy_balancer.so, and mod_jk.so. Is this the connector that I need to use with Apache 2.2.14 ? If it is, I can't seem to get the installation to work. I can't communicate between Apache and Tomcat.

What do you think?

Harry Henriques
 
Harry Henriques
Ranch Hand
Posts: 206
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello,

I guess it is version 1.2.28 of mod_jk.so that is in the /usr/lib/apache2/modules directory.
The current released version is 1.2.31 on the tomcat-connectors website, dated Nov 2010.

This is a snippet from the /var/log/apache2/mod_jk.log
[Fri Jul 01 11:56:15.495 2011] [1220:3075155712] [info] init_jk::mod_jk.c (3183): mod_jk/1.2.28 initialized

Harry
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!