• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Jeanne Boyarsky
  • Devaka Cooray
  • Paul Clapham
Sheriffs:
  • Tim Cooke
  • Knute Snortum
  • Bear Bibeault
Saloon Keepers:
  • Ron McLeod
  • Tim Moores
  • Stephan van Hulst
  • Piet Souris
  • Ganesh Patekar
Bartenders:
  • Frits Walraven
  • Carey Brown
  • Tim Holloway

Running Tomcat 7

 
Ranch Hand
Posts: 386
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have downloaded and installed Tomcat 7 without any error. Now when I am trying to run http://localhost:8080/index.jsp, I am getting 404 error.

Secondly, I tried to configure Tomcat 7 in Eclipse IDE. Here I am getting the message,
"starting Tomcat7 at localhost has encountered a problem
Several ports (8080, 8009) required by Tomcat v7.0 Server at localhost are already in use. The server may already be running in another process, or a system process may be using the port. To start this server you will need to stop the other process or change the port number(s)."

How can I find out what services are running at port 8080 ? If any service is running at 8080, can I just stop the service and I will be able to run Tomct on 8080 ?

I did "netstat -p tcp -ano"

I got processs 4656 runing at port 8080, 8181 and 8686.

Now when I checked in task manager, I cant find any service with PID 4656. Highest PID is 4084. There some processes for which there is no PID specified ie in task manager PID field for some processes is blank.

Thanks
 
Greenhorn
Posts: 6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
If you edit server.xml, Tomcat7 should listen ports other than 8080 or 8009.
If you don't use tomcat in conjunction with apache httpd (AJP protocol), you can disable 8009 by commenting out "<Connector port="8009" protocol="AJP/1.3" redirectPort="8443" />" line.
 
Don't get me started about those stupid light bulbs.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!