• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Bear Bibeault
  • Liutauras Vilda
Sheriffs:
  • Jeanne Boyarsky
  • Junilu Lacar
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Jj Roberts
  • Tim Holloway
  • Piet Souris
Bartenders:
  • Himai Minh
  • Carey Brown
  • salvin francis

Weblogic Connection Pool Issue

 
Ranch Hand
Posts: 238
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi

We have a weblogic server. We have following settings in our connection pool. The problem we are haing is that the connection pool is apparently giving stale connections (or so we think). Do you see anything that we can improve in the following xml file?

Thanks for your help
Imad

 
Greenhorn
Posts: 9
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
1. What verison of WebLogic server are you using?
2. What do you mean by stale?
 
Muhammad Imad Qureshi
Ranch Hand
Posts: 238
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
1. We are using 10.3

2. By stale I mean connection that is not good. We get connection closed error. Although the property "test connection on reserve" is "true". I also see in my database "select count(*) from dual" query run by weblogic user very often. And this connection drop happens only occasionally. Let's say two or three times a day. But it must be fixed. It may not be weblogic and something else (perhaps cluster or the driver), but I need to prove that. Any help is really appreciated.

Thanks
Imad
 
Greenhorn
Posts: 5
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
check the DB connection pool and monitor the no of connection constantly and check the no of connection.this might be this type of issue. also check the code if connections are released corrctly.
 
He's dead Jim. Grab his tricorder. I'll get his wallet and this tiny ad:
the value of filler advertising in 2020
https://coderanch.com/t/730886/filler-advertising
reply
    Bookmark Topic Watch Topic
  • New Topic